in-Tanz

Tests for Chrome

Problem: links into Flash - deep links

Chrome versions 21 - today (32-bit and 64-bit versions on Windows - XP up to Windows 10) do no longer jump to Flash-links like
http://www.in-tanz.de/.../poly-9.php#zwei
All other browsers do resp. earlier Chrome-versions did jump correctly to frame / reference #zwei.

Chrome versions 21 - today always jump to the beginning of the animation (i.e. #eins).

green: OK
red: Chrome bug

Though, the examples above are written in php, they are purely static. All dynamic aspects were removed for this test. Still, I offer a .html version as well.

The bug can be reproduced, when a link is pointing into another .swf-File. Then deep-links will not work.
As long as internal links are used within the same Flash-file, deep links will work properly.

If you click on the links #zwei, #drei, #vier, #fuenf or #sechs on the first page / Flash-animation (-4.swf), Chrome versions 21 - today jump to #eins (=1.) at the beginning of the other animation (-9.swf), instead of the frames further on.

Mind the number in the headline of each animation: 1., 2., 3., 4. etc.

Major problem

This is not a minor problem, as only my web-site contains over 14,000 Flash files with more than one hundred thousand links affected as described above.

Earlier behaviour

Everything worked fine till July 2012 with Chrome 0 to 20.

In August 2012 this bug was implemented in Chrome 21.

It seems to affect at least 32-bit versions on Windows and today even all 64-bit versions.

This Bug was reportetd to Google on 7th of August 2012 as issue 141089.
Still, it has neither been fixed nor answered.

Top

Login
Impressum
AGB
Kontakt
Figuren-Suche